Spike in the BTC network fees
Incident Report for Paybis
Resolved
This incident has been resolved.
Posted Dec 31, 2023 - 21:31 UTC
Monitoring
Dear Customers,

Due to the recent surge in Bitcoin (BTC) network fees, we must increase the minimum transaction amount from 5 USD to 50 USD across all payment methods.

We sincerely apologize for any inconvenience this may cause. This situation is beyond our control. Rest assured, our team is closely monitoring the network, and we will revert the transaction limits to their normal values as soon as the network fees stabilize.

Best regards,
The Paybis Team
Posted Dec 17, 2023 - 18:15 UTC
This incident affected: Cryptocurrency Payouts (Bitcoin (BTC)).