Issues accessing Corporate pages

Incident Report for Paybis

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 15:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 19, 2026 - 15:27 UTC

Identified

We are currently experiencing an issue affecting Corporate pages for some UK users, where certain content may not load correctly.

Our team has identified the cause and is actively deploying a fix. We apologize for the inconvenience and will provide an update as soon as the issue is resolved.
Posted Jan 19, 2026 - 12:22 UTC
This incident affected: Paybis site (Paybis.com).