BTC Withdrawal Delays
Incident Report for Paybis
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 18:08 UTC
Investigating
We have observed a delay in processing certain BTC withdrawals. Our team is aware of the issue and is actively working on resolving it. We anticipate a solution within the next 2 hours
Posted Feb 20, 2024 - 15:39 UTC
This incident affected: Cryptocurrency Payouts (Bitcoin (BTC)).