Intermittent transaction processing delays in the US region

Incident Report for Paybis

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 18:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2026 - 18:12 UTC

Identified

We are continuing to work on resolving this issue. Some transactions may be delayed but will be processed once the issue is resolved
Posted Jun 29, 2026 - 16:34 UTC
This incident affected: Cryptocurrency Payouts (ERC-20 (Ethereum), Bitcoin (BTC), Solana (SOL), Litecoin (LTC)).