Crypto Wallets: Incoming Transaction Issues on TON, Ripple, and Stellar blockchains

Incident Report for Paybis

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 11:13 UTC

Investigating

Dear customers,

Our Crypto Wallets infrastructure is currently experiencing an issue affecting incoming transactions on the TON, Ripple, and Stellar blockchains.

We are actively investigating this issue.

Thank you for your patience and understanding,
The Paybis Team
Posted Jun 30, 2026 - 23:48 UTC
This incident affected: Crypto wallets (Deposits).