Infrastructure Connectivity Incident

Incident Report for Paybis

Resolved

All Paybis services are functioning normally, and earlier issues have been resolved.
Posted Nov 18, 2025 - 18:03 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 17:33 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 17:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 14:52 UTC

Update

We continue to work with our infrastructure provider and monitor the situation closely.
Posted Nov 18, 2025 - 14:40 UTC

Update

No new updates at this time. We continue to work with our infrastructure provider and monitor the situation closely.
Posted Nov 18, 2025 - 14:26 UTC

Update

We continue to work with our infrastructure provider and monitor the situation closely. We will provide further updates as they become available.
Posted Nov 18, 2025 - 13:39 UTC

Update

No new updates at this time. We continue to work with our infrastructure provider and monitor the situation closely.
Posted Nov 18, 2025 - 13:15 UTC

Update

We are observing early signs of improvement regarding website availability. However, some users may still experience intermittent issues and delays.

We continue to monitor the situation closely and are working to restore full operation as quickly as possible. We will provide further updates as they become available.
Posted Nov 18, 2025 - 12:37 UTC

Identified

We are experiencing intermittent service disruptions due to a global issue with our core infrastructure provider.
You may notice problems with website functionality or experience delays.
We are monitoring the situation closely and working to resolve it as quickly as possible. We will provide updates as they become available.
Posted Nov 18, 2025 - 12:05 UTC
This incident affected: Mobile Application (iOS Application, Android Application), Cryptocurrency Payouts (ERC-20 (Ethereum), TRC-20 (TRON), BEP-20 (Binance Smart Chain), Bitcoin (BTC), Ripple (XRP), Polkadot (DOT), Stellar (XLM), Bitcoin Cash (BCH), Tezos (XTZ), Cardano (ADA), Solana (SOL), Polygon (POL), USD Coin (USDC) Polygon, Tether (USDT) Polygon, Litecoin (LTC)), Payment methods (Debit / Credit Cards, Apple Pay, Google Pay, Skrill, Neteller, Bank Transfer), Paybis site (Paybis.com, Verification, Login, Registration, OTP & SMS Notifications, Blog, Crypto calculator, Prices, Support chat), and Crypto wallets (Deposits, Withdrawals).