Intermittent delays with Ripple transactions
Incident Report for Paybis
Resolved
This incident has been resolved.
Posted Dec 31, 2023 - 21:30 UTC
Identified
We are currently investigating this issue.
Posted Dec 31, 2023 - 15:52 UTC
This incident affected: Cryptocurrency Payouts (Ripple (XRP)).