Paybis service outage
Incident Report for Paybis
Resolved
The issue has been resolved and services have returned to their operational state.
Posted Jun 13, 2023 - 22:01 UTC
Monitoring
We are seeing services recovery and will provide further updates as they become available.
Posted Jun 13, 2023 - 20:57 UTC
Identified
Dear customers,

We regret to inform you that we are currently experiencing technical issues due to Operational issues in AWS US-EAST-1 (N. Virginia), which may affect some of our services.

We understand the importance of our services to you, and we want to assure you that we are doing everything we can to rectify the situation.

We thank you for your patience and understanding during this time and will provide updates as soon as they become available.

Sincerely,
The Paybis Team
Posted Jun 13, 2023 - 19:36 UTC
This incident affected: Paybis site (Paybis.com, Verification, Login, Registration, OTP & SMS Notifications, Crypto calculator, Prices) and Crypto wallets (Deposits, Withdrawals).