Delays in transaction processing

Incident Report for Paybis

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 15:30 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 05, 2026 - 15:07 UTC

Investigating

We are currently investigating this issue.
Posted Mar 05, 2026 - 12:25 UTC
This incident affected: Cryptocurrency Payouts (Solana (SOL), Polygon (POL), USD Coin (USDC) Polygon, Tether (USDT) Polygon).