Paybis Suffers DDoS Attack: An Important Update for Our Customers
Incident Report for Paybis
Resolved
This incident has been resolved.
Posted Aug 10, 2023 - 14:48 UTC
Identified
Dear Paybis Customers,

We wish to inform you about a recent Distributed Denial of Service (DDoS) attack that targeted our platform. We understand the concerns and frustrations that such incidents may cause, and we are committed to keeping you informed and protected.

Key Details:

1. Impact on Services: Due to the attack, users might have experienced temporary difficulties accessing our platform or slower response times. We apologize for any inconvenience caused.

2. Customer Data and Funds: As of our latest assessment, there is no evidence to suggest any customer data or funds have been compromised. The attack was aimed at overwhelming our servers, rather than extracting information.

3. Countermeasures: We have fortified our defenses and increased our bandwidth capacity to handle such attacks in the future. Additionally, we're working with cybersecurity experts to ensure we're prepared for potential threats.

4. Future Preparedness: We're investing in further advanced security measures and enhancing our infrastructure to prevent similar occurrences.

For ongoing updates and more detailed information regarding the situation, please visit our status page at https://status.paybis.com/.

We deeply regret the inconvenience caused. At Paybis, our customers' trust and security are of paramount importance. We are taking every necessary step to ensure our platform remains secure and resilient against such threats.

Thank you for your patience and understanding. Should you have any queries or concerns, please reach out to our dedicated customer support team.

Warm regards,

The Paybis Team
Posted Aug 10, 2023 - 12:49 UTC
This incident affected: Mobile Application (iOS Application, Android Application) and Paybis site (Paybis.com, Verification, Login, Registration, OTP & SMS Notifications, Blog, Crypto calculator, Prices).