Intermittent delays in Polygon network transaction processing

Incident Report for Paybis

Resolved

This incident has been resolved.
Posted Nov 27, 2025 - 17:48 UTC

Update

We are continuing to investigate this issue.
Posted Nov 27, 2025 - 16:35 UTC

Investigating

Dear Valued Customers,

We are currently experiencing intermittent delays in Polygon network transaction processing. Our team is actively investigating the issue and working to restore normal processing times as soon as possible.

Thank you for your patience and understanding,
The Paybis Team
Posted Nov 27, 2025 - 15:38 UTC
This incident affected: Cryptocurrency Payouts (Polygon (POL), Tether (USDT) Polygon).