Resolved
Thank you for your patience and support during while we got back online today. If you have any pending or unprocessed transactions, please contact support@paybis.com
Posted Oct 20, 2025 - 20:41 UTC
Update
We are seeing improvements and the service is available again. Some residual delays may still occur while recovery completes. We’re monitoring closely and will provide further updates as needed.
Posted Oct 20, 2025 - 20:08 UTC
Update
No new updates from our infrastructure provider. We are closely monitoring the situation and will share further updates as they become available.
Posted Oct 20, 2025 - 19:32 UTC
Update
We are seeing gradual improvements from our infrastructure provider. Previously created transactions have started processing. We’re monitoring closely and will provide further updates as recovery continues.
Posted Oct 20, 2025 - 19:01 UTC
Update
Our infrastructure provider continues to apply mitigation steps and is seeing steady recovery in service connectivity. An additional measures are being implemented to fully restore normal operations.
We are closely monitoring the progress and will provide further updates as needed.
Posted Oct 20, 2025 - 17:17 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 15:15 UTC
Update
Our infrastructure provider is still experiencing issues and is actively working toward a full resolution.
Our team is monitoring the situation closely and will provide further updates as progress is made.
Posted Oct 20, 2025 - 14:20 UTC
Update
Our infrastructure provider is actively working toward a full resolution.
We continue to monitor the situation closely and will provide further updates as progress is made.
Posted Oct 20, 2025 - 12:33 UTC
Update
AWS reports that services in US-EAST-1 (N. Virginia) are still experiencing increased error rates and they are continuing to work toward full resolution. We’re monitoring closely and will keep you informed of further progress.
Posted Oct 20, 2025 - 10:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 10:25 UTC
Update
AWS has identified the root cause of the issue in the US-EAST-1 (N. Virginia) region and is actively working on a resolution.
We continue to monitor the situation and will provide further updates as progress is made.
Posted Oct 20, 2025 - 10:22 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 08:52 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 08:48 UTC
Investigating
Dear Valued Customers,
We would like to inform you that we are currently experiencing partial service degradation due to ongoing operational issues in the AWS US-EAST-1 (N. Virginia) region.
We understand the importance of our services to you, and we want to assure you that we are doing everything we can to rectify the situation.
We thank you for your patience and understanding during this time and will provide updates as soon as they become available.
Sincerely,
The Paybis Team
Posted Oct 20, 2025 - 07:31 UTC
This incident affected: Mobile Application (iOS Application, Android Application), Cryptocurrency Payouts (ERC-20 (Ethereum), TRC-20 (TRON), BEP-20 (Binance Smart Chain), Bitcoin (BTC), Ripple (XRP), Polkadot (DOT), Stellar (XLM), Bitcoin Cash (BCH), Tezos (XTZ), Cardano (ADA), Solana (SOL), Polygon (POL), USD Coin (USDC) Polygon, Tether (USDT) Polygon, Litecoin (LTC)), Payment methods (Debit / Credit Cards, Apple Pay, Google Pay, Skrill, Neteller, Bank Transfer), Paybis site (Paybis.com, Verification, Login, Registration, OTP & SMS Notifications, Blog, Crypto calculator, Prices, Support chat), and Crypto wallets (Deposits, Withdrawals).