Intermittent Transaction Processing Issue in US Region

Incident Report for Paybis

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 10:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2026 - 10:14 UTC

Update

Our team continues to work on resolving this issue and we’re optimistic that the incident will be resolved soon.
Posted Jan 22, 2026 - 09:07 UTC

Update

We are continuing to work on a fix for this issue and are closely monitoring the situation.
Posted Jan 22, 2026 - 06:59 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jan 22, 2026 - 05:50 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jan 22, 2026 - 04:19 UTC

Identified

Dear Valued Customers,

We are currently experiencing intermittent technical issues that may affect transaction processing for some users in the US region.

Our team is investigating the root cause and working to resolve the issue as quickly as possible.

Thank you for your patience and understanding.
The Paybis Team
Posted Jan 22, 2026 - 01:33 UTC
This incident affected: Cryptocurrency Payouts (ERC-20 (Ethereum), TRC-20 (TRON), BEP-20 (Binance Smart Chain), Bitcoin (BTC), Ripple (XRP), Polkadot (DOT), Stellar (XLM), Bitcoin Cash (BCH), Tezos (XTZ), Cardano (ADA), Solana (SOL), Polygon (POL), USD Coin (USDC) Polygon, Tether (USDT) Polygon, Litecoin (LTC)).