We are continuing to analyze the root cause of the instability.
Posted Nov 23, 2025 - 07:20 UTC
Update
Intermittent outages are still occurring. Investigation and mitigation efforts are ongoing.
Posted Nov 23, 2025 - 05:00 UTC
Update
We are detecting renewed instability. Access to Paybis.com is currently intermittent. We are continuing our efforts to stabilize the system.
Posted Nov 23, 2025 - 04:07 UTC
Update
Service has been restored. We are continuing our investigation to prevent recurrence.
Posted Nov 23, 2025 - 04:02 UTC
Update
We are continuing to investigate this issue.
Posted Nov 23, 2025 - 03:48 UTC
Update
We are continuing to investigate the situation. The issue is persisting, and our technical team remains fully focused on resolving it. We will provide further updates as soon as we make progress.
Posted Nov 23, 2025 - 03:37 UTC
Update
We are still diagnosing the root cause of the connectivity issues. Restoring service remains our top priority.
Posted Nov 23, 2025 - 02:56 UTC
Update
We are continuing to investigate the issue affecting Paybis.com availability. Our engineering team is actively working to identify the root cause. We will provide another update as soon as we have more information.