Intermittent delays in transaction creation

Incident Report for Paybis

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 20:21 UTC

Identified

Dear valued customers,

We are currently experiencing technical issues affecting the creation of transactions.

Our team is actively investigating the issue and working to restore normal processing times as soon as possible.

Thank you for your patience and understanding,
The Paybis Team
Posted Nov 20, 2025 - 19:28 UTC
This incident affected: Payment methods (Debit / Credit Cards, Apple Pay, Google Pay) and Paybis site (Verification).