Temporary Disruption of EUR Payment Methods for UK Users

Incident Report for Paybis

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 18:13 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jan 22, 2026 - 17:07 UTC

Identified

Dear Valued Customers,

We are currently experiencing an issue affecting the availability of EUR payment methods for Buy Crypto for UK users.

Our team has identified the root cause and is working to resolve the issue as quickly as possible.

Thank you for your patience and understanding.
The Paybis Team
Posted Jan 22, 2026 - 13:46 UTC
This incident affected: Payment methods (Debit / Credit Cards, Apple Pay, Google Pay, Bank Transfer).