Spike in the BTC network fees
Incident Report for Paybis
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 13:36 UTC
Monitoring
Dear Customers,

We regret to inform you that there are delays in processing Bitcoin (BTC) transactions due to the recent surge in network fees.
This situation is beyond our control.

Best regards,
The Paybis Team
Posted Apr 20, 2024 - 11:14 UTC
This incident affected: Cryptocurrency Payouts (Bitcoin (BTC)).