We're currently experiencing issues with Google Pay payments on Paybis. Our team is aware of the problem and is actively working to resolve it as quickly as possible.
Posted Apr 03, 2026 - 07:35 UTC
Investigating
We are currently investigating this issue.
Posted Apr 03, 2026 - 06:15 UTC
This incident affected: Payment methods (Google Pay).